Back to overview
Degraded

WordPress Hosting Platform Outage

Mar 25, 2026 at 10:51am UTC
Affected services
WordPress Hosting Platform

Resolved
Mar 25, 2026 at 10:58am UTC

This incident has been resolved.

Updated
Mar 25, 2026 at 10:55am UTC

We have identified the root cause of the issue. We are working on a fix.

Created
Mar 25, 2026 at 10:51am UTC

We are experiencing an issue with our WordPress hosting platform. Our team is investigating the incident.